NEW RELEASE:

Centralized data layer for multiple content sources or frameworks. Dive deep into Valhalla

v5.2 Release Notes

Welcome to gatsby@5.2.0 release (November 2022 #3)

This is an out of band release due to the removal of the Potrace library in Gatsby. We’ll continue with our biweekly schedule as normal.

Also check out notable bugfixes.

Bleeding Edge: Want to try new features as soon as possible? Install gatsby@next and let us know if you have any issues.

Previous release notes

Full changelog


Removal of Potrace

Due to licensing requirements, we are removing the Potrace library usage from Gatsby. Potrace is used in Gatsby’s image transformations, specifically for creating a SVG placeholder. For example, in gatsby-plugin-image you were able to use it with tracedSvg and TRACED_SVG respectively.

These are the affected libraries/plugins:

  • gatsby-plugin-sharp
  • gatsby-transformer-sharp
  • gatsby-plugin-utils
  • gatsby-remark-images

There will be no API-breaking changes, your builds will continue to work. However, whenever you use the tracedSvg feature Gatsby automatically falls back to the default placeholder style now. In most instances this is DOMINANT_COLOR. You’ll see a detailed warning message in your CLI about this, too.

If you’d like to know more or have any questions, head over to our Github Discussion.

Notable bugfixes & improvements

  • gatsby-source-wordpress: MediaItem.excludeFieldNames / auto exclude interface types that have no fields, via PR #37062
  • gatsby-source-drupal: Provide proxyUrl in addition to baseUrl to allow using CDN, API gateway, etc., via PR #36819
  • gatsby-cli: We changed our error messages a little bit. You should see a more detailed type beside the error ID now
  • gatsby: Sanitize length on objects, via PR #34253

Contributors

A big Thank You to our community who contributed to this release 💜

Edit this page on GitHub
© 2022 Gatsby, Inc.