Skip to main content
Community Plugin
View plugin on GitHub
See starters using this

🎩 gatsby-remark-abbr

Add abbreviation syntax support to Gatsby.

With this plugin, you’ll be able to write in your Markdown pages:

The HTML specification
is maintained by the W3C.

*[HTML]: Hyper Text Markup Language
*[W3C]:  World Wide Web Consortium

And it’ll be converted to:

<p>
  The <abbr title="Hyper Text Markup Language">HTML</abbr> specification
  is maintained by the <abbr title="World Wide Web Consortium">W3C</abbr>.
</p>

Installation

  1. Add the package to your project:
  2. With yarn:

    yarn add gatsby-remark-abbr
  3. With npm:

    npm install gatsby-remark-abbr
  4. Add those few lines into your gatsby-config.js:

      module.exports = {
        plugins: [
          {
            resolve: 'gatsby-transformer-remark',
            options: {
  5. plugins: [
  6. ‘gatsby-remark-abbr’,
  7. ], }, }, };

  8. Delete .cache/ and reboot gatsby
  9. You can now enjoy markdown abbreviation syntax 🎉

Todo

Currently, some code is duplicated between remark-abbr and this plugin. I haven’t figured it out yet how to do avoid this. Any help will be greatly apreciated 😅

License

It’s a wrapper around remark-abbr plugin, which is under MIT license.